• 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
3.1 TBI Misfire
On our 200+ miles trip for Easter holidays the Pontiac TS 3.1L TBI engine started to miss under acceleration and lose power uphill.

After a few minutes everything came back to normal and we made it ok to our destination but some misfire can still be heard at idle.

I have attached the audio recording of it at

If you have encoutered this problem or you have an idea on where we should start troubleshooting this issue you are most welcome!

Thank you!

Angehängte Dateien
.zip (Größe: 321,89 KB / Downloads: 2)
Hey Meridivs,

it seems to be an ignition problem. Check spark plugs and spark plug wires.

Rough idle can be caused by a worn EGR Valve. To eliminate this part from being the cause of rough idle, disconect its vacuum hose but lock the the connection to the vacuum actuator.

Losing power uphill could be caused by the mentioned ignition problem or the fuel system - pressure regulator e.g.

Kind regards

Even check the Distributor and the distributorcap, maybe the are damaged or carbunatet, check the ignitiontiming
[Bild: 16083226cl.jpg]
94er 3,1er TS US - just in work
95er 3,8er TS Canada - full options
05er Kia Sorento 2,5 CRDi als Daily
Suzuki Marauder just 4 fun

Leben ist zeichnen ohne Radiergummi
Changed spark plug wires and plugs with new parts (Delphi wires). No change.

On the OBD I interface I get code 22 (TPS sensor voltage low). Ordered the TPS and EGR, will post after replacing those.

Will also check the ignition timing (have to find that lamp Smile.

Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste